MyPBX - Access problems
Incident Report for IPFone
Resolved
This incident has been confirmed as resolved.
Posted Jun 06, 2024 - 11:23 EDT
Monitoring
We have applied a solution and are currently monitoring the system. If you encounter any issues with MyPBX, please contact our Support team at 305-573-5300, Option 3. Thank you.
Posted Jun 06, 2024 - 10:41 EDT
Investigating
We have detected issues with logging into the MyPBX platform. Our team and vendors are actively addressing this matter. Further updates will be provided shortly. Please note that phone services are not affected by this issue. Thank you for your patience and cooperation.
Posted Jun 06, 2024 - 10:02 EDT
This incident affected: MyPBX.